Impressum Suchfunktion

NOF-Schule | Forum

zur Schule NOF-NetObjects-Tutorials von Tommy Herrmann


Umlaute werden nicht dargestellt
#1
Hallo zusammen, auf unserer Seite http://www.klecks-verlag.de steht seit Jahren ein Formular (mit NOF 15 erstellt). in den daraus generierten Mails werden in Outlook keine Umlaute angezeigt sondern Sonderzeichen und Quadrate. Im Quelltext der Mail sind die Umlaute jedoch enthalten.
Kann jemand helfen?

Mit besten Grüßen 
Ralf
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#2
Moin Ralf,

und willkommen bei uns im Forum Smiling

Das wird wohl daran liegen, dass Du Deine Seiten noch auf einem ISO-Format stehen hast:

Zitat:<meta charset="ISO-8859-1"/>

Es muss dagegen heute das "UTF-8" Format verwendet werden, da ab PHP 5.6 das ISO-Format nicht mehr verarbeitet werden kann.

Das Mail-Script von NOF15 ("FormHandler.php") ist nämlich auf "UTF-8 ohne BOM" konvertiert und Deine Formular-Seite ("kontakt.html") auf ISO. Mit dem POST-Befehl werden dann die Eingaben im ANSI-Format an ein Skript im UTF-8 Format übergeben und das kann und wird nicht funktionieren.

Das Format muss immer auf allen verwendeten Seiten gleich sein.

Stelle Deine Seiten (zumindest die Kontakt-Seite mit dem Formular) auf "UTF-8" um und publiziere diese neu.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#3
hallo zusammen,

ich weiss nicht mehr weiter. brauche dringend eure hilfe.
obwohl ich in nof13 auf utf-8 eingestellt habe, werden mir keine umlaute dargestellt.
aber nur auf dem server. lokal ist alles ok.
hat jemand einen tipp für mich.danke und gruß
peter
http://www.peterzinnhardt.de/$extras...l/tanz.php
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#4
Moin Peter,

da bräuchten wir mal einen Link zu Deiner Seite um gucken zu können.

Es müssen alle Teile einer Seite auf UTF-8 (ohne BOM) stehen. Das ist bei NOF 2013 nicht zwingend der Fall (derweil zu alt). Das könnte insbesondere auf PHP-Seiten auftreten, bei Komponenten und auch z.B. bei falsch kodierten CSS-Dateien - denn ab PHP 5.6 ist UTF8 zwingend erforderlich.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#5
Du hast da aber auch viele Fehler drinnen :eek:

> der DOCTYPE geht gar nicht - der steht noch auf "Quirks" - gucke mal hier:

http://www.tommyherrmanndesign.com/nof/h...ctype.html

> ganz unten auf der Seite ist ein verlorenes "</center>"

Wie hast Du den Text eingefügt? Der darf keine ANSI-Kodierung haben, sondern muss auch in UTF-8 (ohne BOM) konvertiert sein. Mache das über einen Editor wie "Notepad++", da kannst Du die Kodierung sehen und auch einstellen.

... überlege, was Du auf den anderen Seiten anders gemacht hast - da stimmt es doch :

http://www.peterzinnhardt.de/$extras...ehrung.php
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#6
Shocked 
danke, lieber thommy, hab´eine lösung gefunden, da kommt schon das nächste problem.

wollte deinen flash-mp3-player um eine mp3-datei erweitern.

mp3 lied auf server. ok

playlist manuell erweitert. ok

name der neuen mp3 erscheint nicht im player Surprised

help !!!!!! lieber thommy
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#7
Moin Peter,

es ist immer besser einen Link zu meinem Tutorial und Deiner Seite zu posten, sodass man weiß wovon wir sprechen. Meinst Du diesen Player hier?

http://www.tommyherrmanndesign.com/nof/h...layer.html

Bei dem Flash-Player werden die Titel in einer Textdatei eingetragen - Beispiel:

../Pfad-Verzeichnis/Musikdatei.mp3|Titel

Zitat:../mp3player/TomTomBrazil_1.mp3|Tom Tom Brazil
../mp3player/alsiestamar_1.mp3|Alsiestamar
../mp3player/citylights_1.mp3|Citylights

Dir ist bewusst, dass Flash nicht am mobilen Gerät, wie dem Smartphone, angezeigt wird?! Du solltest heute nur noch HTML5 Player verwenden - auch dafür habe ich etliche Beispiele und Anleitungen auf meinen Seiten.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#8
hallo zusammen,
es ist wirklich zum verzweifeln- mit utf-8 -
habe nof13.
unter optionen steht die einstellung auf utf-8
in der lokalen puplizierung wird alles ordnungsgemäß dargestellt.

nur ... auf dem server stehen keine umlaute..

bitte um hilfe.
danke im voraus und gruß
peter
http://www.peterzinnhardt.de/lebensfreud.../traum.php
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#9
Aktuell hast du 2 Einträge im Quelltext:
Code:
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=ISO-8859-1">
Entferne erst einmal die Zeile mit "ISO-8859-1"!
Evtl. hängt das auch mit php zusammen. Ich hatte mal ein Problem, wo der Server mein "utf-8" nicht genommen hat.
Keine Zeit, muss Haare machen!
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#10
danke... hab ich erledigt. hilft nicht.

alle weiteren seiten werden ordnungsgemäß dargestellt.

erst bei einem text-edit und puplizierung kam das problem.
kann es sein , dass nof13 neu installiert werden sollte?
oder.. auf nof15 upgraden?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#11
hallo zusammen,

hab´alles per notepad+ manuell geändert.

nun läuft es, ist aber sehr umständlich. Smiling

danke für die ratschläge.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#12
(12.10.2017, 21:03)petz schrieb: alle weiteren seiten werden ordnungsgemäß dargestellt.

Optisch vielleicht, aber im Quelltext (sprich den Meta-Tags) sieht es anders aus.

.jpg  Aufnahme1.jpg (Größe: 191,75 KB / Downloads: 9)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#13
@Raven,

die Meta-Tags wurden erst mit Update1 von NOF15 für Sonderzeichen von NOF in Ordnung gebracht. Da kann er nichts mit NOF 2013 dagegen tun.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#14
Naja, er kann ja die UE, OE, oder AE Varianten nehmen, immer noch besser als .
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  NOF Responsive Slider wird auf den Unterseiten nicht richtig angezeigt funsport 2 55 Gestern, 08:43
Letzter Beitrag: Raven
  Publizierung NOF 12 geht nicht seejungfrauxs 3 121 20.09.2017, 19:03
Letzter Beitrag: Wolfgang Z
  Header und Fooder scrollen nicht... Schmuckwirker 8 173 23.08.2017, 12:19
Letzter Beitrag: Tommy Herrmann
  Meta Tag Umlaute wigg 3 159 19.08.2017, 18:18
Letzter Beitrag: wigg
  Seite wird online nicht aufgerufen km86 13 288 30.07.2017, 16:21
Letzter Beitrag: immergut
  Carousel in NOF 15 funktioniert nicht richtig Swedi 62 2.247 25.07.2017, 13:57
Letzter Beitrag: Swedi
  Sicherung nicht möglich bruns 3 141 20.07.2017, 21:46
Letzter Beitrag: bruns
  Schriftart festlegen klappt nicht immo 16 489 24.06.2017, 17:26
Letzter Beitrag: immo
  Tabellen werden am Tablet kleiner dargestellt Schwalbe 4 195 17.06.2017, 22:34
Letzter Beitrag: Martin73
  Seite mit Endung _nof.js nicht gefunden Ludmilla 3 151 14.06.2017, 18:01
Letzter Beitrag: Doris Rehhausen



Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
nach oben An den Anfang der Seite scrollen
NetObjects Fusion Infos, Downloads und Updates Diese Website wird durch Bot-Trap vor Spam geschützt!