Datenschutz Impressum

NOF-Schule | Forum

zur Schule NOF-NetObjects-Tutorials von Tommy Herrmann


Assets werden bei Vorlage erstellen nicht gefunden
#1
Hallo mal wieder....
Ich musste meinen Rechner neu aufsetzen und bin nach besten Wissen und Gewissen vorgegangen. (W10/64pro).
NOF 2015 inkl. Updates installiert, Vorlage geholt und einzelne Seiten bearbeitet - ok...
Jetzt wollte ich eine neue Vorlage erstellen und die Assets werden nicht mehr gefunden, obwohl vorhanden (siehe Bild).
Gibt es da einen Workarround oder was habe ich jetzt wieder falsch gemacht?
Danke (mal wieder) im Vorfeld :-)


.jpg  Fehler_NOF.JPG (Größe: 121,88 KB / Downloads: 21)
NOF 2015 - irgendwann begreife ich dich... Irgendwann!!!
Ich glaube, der Fehler sitzt vorm Bildschirm :-(
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#2
Hast Du das Projekt gespeichert, dann wieder geöffnet? Manchmal kommen Assets wieder zum Vorschein.

Website erneut optimieren versucht?
Lieben Gruß
Barbara
--------------
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#3
Hallo Barbara,
ja - Projekt geschlossen und wieder geöffnet. Optimieren auch versucht..
Die Assets sind ja wie auf dem Bild alle da. Auch verweist NOF genau auf dieses Verzeichnis mit den Dateien... Obwohl alles da und er Link dahin ja gezeigt wird, werden diese scheinbar nicht gefunden..
Auch das letzte Projekt von April, wo noch eine Vorlage erstellt wurde kann jetzt nicht mehr als Vorlage gespeichert werden.
Die geänderte Seite von heute kann nicht geöffnet werden "Diese Datei ist schon geöffnet"....
Oh-Mann...
NOF 2015 - irgendwann begreife ich dich... Irgendwann!!!
Ich glaube, der Fehler sitzt vorm Bildschirm :-(
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#4
Moin,

hattest Du NOF als "Administrator" installiert und das Update 1 auch? Das ist zwingend notwendig.

Falls nicht, musst Du NOF deinstallieren und nochmals als Administrator (rechte Maustaste auf .exe und wählen "Ausführen als Administrator") installieren.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#5
Nur so eine Idee: Hast Du den Pfad in Deinem Screenshot gesehen? Es sind temporäre Dateien. Leider weiß ich nicht mehr genau, wo sie hingehören, aber...

Was sagt Deine Assetsverwaltung in NOF? Sind diese Dateien in Verwendung oder nicht? Wenn nicht > löschen. Wenn ja mit 0KB > löschen.
Lieben Gruß
Barbara
--------------
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#6
Die Assets werden beim Publizieren (generieren der Seiten) grundsätzlich von NOF in dieses temporäre Verzeichnis gelegt und anschließend sogleich wieder gelöscht. Das Verzeichnis hat aber Administrator-Rechte und NOF kann dort nichts ablegen(auslesen) wenn es nicht unter dem Administrator-Namen installiert wurde.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#7
Hallo ihr zwei,

NOF wurde als Administartor installiert, das Update auch.

Den Pfad habe ich gesehen, aber der ist ja bei der Fehlermeldung gleich dem was wirklich vorhanden ist.
Ich verstehe den Fehler so, das er in dem Pfad die Assets nicht finden kann, obwohl vorhanden.
Oder schaut er in das Temp-Verzeichnis und sucht die gefunden Assets im Verzeichnis dann im Projekt?

Assetverwaltung.. Habe schon nach gegoogelt, aber ich finde keinerlei Reiter/Lasche zur Assetverwaltung in NOF 2015


Wie gesagt, hat es beim letzten mal im April noch funktioniert, die Vorlage habe ich ja noch. Aber von diesem Projekt kann ich jetzt keine Vorlage mehr erstellen. Windows wurde im März neu installiert, also vor dem Erstellen der Vorlage April. Danach ist nichts mehr geändert worden am System. Jetzt habe ich nur das Projekt vom April geöffnet und eine kleinere Änderung durchgeführt. Davon kann keine Vorlage erstellt werden, auch nicht mehr vom April Projekt - was ja im April funktioniert hat.

Ich werde jetzt mal den Inhalt des Tempverzeichnisses löschen wenn ich nach Hause komme und testen was passiert.

VG
EinDet
NOF 2015 - irgendwann begreife ich dich... Irgendwann!!!
Ich glaube, der Fehler sitzt vorm Bildschirm :-(
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#8
... hier ist meine Tutorial-Seite zur Assets-Verwaltung von NOF:

http://www.tommyherrmanndesign.com/nof/h...alten.html
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#9
Hallo Tommy,
dein Tutorial kenne ich. Habs jetzt auch gefunden (blind mal wieder)...
Durch diese Verwaltung habe ich doch einige 0KB- Dateien gefunden - sicher 30-40 Stück an der Zahl.
Ich dachte das ich direkt bei den Assets schauen müsste und da natürlich nichts gefunden.
Habe die 0KB Einträge alle gelöscht, jetzt lässt sich auch wieder eine Vorlage erstellen...
Aber wodurch kann so etwas kommen?
Bin jetzt kurz davor die Seite mal an einem anderen Ort zu publizieren, ob diese überhaupt noch vollständig ist...
VG
EinDet
NOF 2015 - irgendwann begreife ich dich... Irgendwann!!!
Ich glaube, der Fehler sitzt vorm Bildschirm :-(
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#10
Update (werde noch irre)
Habe ja die 0KB-Dateien in der Verwaltung entfernt.
Projekt gespeichert und Vorlage erstellt.
Dann das Projekt optimiert, gespeichert und versucht eine Vorlage zu erstellen - geht nicht.
Alle 0KB Dateien wieder da.
Bin ich denn wirklich so dämlich?
VG
EinDet
NOF 2015 - irgendwann begreife ich dich... Irgendwann!!!
Ich glaube, der Fehler sitzt vorm Bildschirm :-(
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#11
... da gibt es viele Möglichkeiten Sad

Du solltest, um diesem Problem vorzubeugen, Dir angEwöhnen grundsätzlich alle Assets (also Bilder usw.) in das verzeichnis "assets" zu kopieren, bevor Du diese überhaupt in NOF einliest. Siese Bilder also dann aus dem Verzeichnis "Assets" einlesen.

C:\Users\ADMINISTRATOR-NAME\Documents\NetObjects Fusion 2015\User Sites\PROJEKT-NAME\Assets

... nichts anderes macht NOF bei der Erstellung einer sogenannten "Vorlage". NOF kopiert dabei alle Dateien in dieses Verzeichnis.

Das aus gutem Grund:

1) Werden am PC später Bilder verschoben oder gelöscht, wird NOF die Pfade zu diesen Bildern nicht mehr finden und als 0KB Einträge in der Assets-Verwaltung anzeigen.

2) Bei einem Umzug zu einer neueren NOF-Version können die Pfade sich verändern und dann wird auch nichts mehr gefunden

3) Bei einem Umzug auf einen neuen PC, also z.B. von Windows7 nach Windows10 wird auch nichts mehr gefunden, da das Dateien-System ein anderes ist.

Daher ist es unerlässlich seine Projekte immer über eine durch NOF erstellte "Vorlage" neu einzulesen, alles andere führt immer genau zu Deinem Problem.

Wenn Du die 0KB Dateien wieder, nach einer Vorlage, hast - dann schleppst Du das schon länger (oder sehr lange) mit Dir herum.

... dann hilft eventuell das Optimieren des Projektes:

> Werkzeuge > Site erneut optimieren

... aber ACHTUNG, es kann (eventuell) dabei von NOF alles gelöscht werden. Du musst eine funktionierende Sicherung als "Vorlage" haben, bevor Du das machst.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#12
Ja, ich habe für meine Webseiten einen anderes Dokumentenverzeichnis. Diese Verzeichnisse schleppe ich auch immer mit mir rum und sind immer an der selben Stelle.
Wie es hier aussieht, scheinen das NOF eigene Assets zu sein - woher auch immer. Diese sind einmal in einem alten Verzeichnis von NOF 2014 laut der Assetverwaltung und das sind die 0KB-Dateien. Diese Struktur gibt es bei mir schon seit 2-3 Jahren nicht mehr.
Genau die gleichen Assets gibt es nochmal im Strukturverzeichnis von NOF2015, die OK sind und auch gefunden werden.
Optimieren der Seite mache ich regelmäßig.
Für mich ist ist es jetzt nur sehr komisch, das nach dem Löschen der 0KB Dateien alles OK erscheint - ich kann das Projekt speichern und auch eine Vorlage erstellen.
Speichere ich das Projekt nur unter einem neuen Namen, ist das Problem der 0KB Dateien und der nicht funktionierenden Vorlage wieder da....
Und das verstehe ich einfach nicht.
NOF 2015 - irgendwann begreife ich dich... Irgendwann!!!
Ich glaube, der Fehler sitzt vorm Bildschirm :-(
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#13
wenn Du eine Vorlage erstellen kannst, umso besser.

Erstelle Dein Projekt neu, eben aus dieser Vorlage; nicht mit dem alten fehlerbehafteten Ding weiterarbeiten.
Auf 'Speichern unter...' solltest Du generell verzichten, lieber ein weiteres Projekt aus der funktionierenden Vorlage mit anderem Namen erstellen - zu welchem Zweck auch immer Wink
viele Grüße
coco

RocketCake 2.1/NOF 2015 /win10prof/64/Freund der Insel Elba. Eigene kleine RC-Websites Wohnangebote: elba-app.de, Casa Heidrun, Acquamarina, Villa Ombrosa, Gallo Nero, Paradiso, ai Peri usw.


Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#14
Habe bereinigt, gespeichert und Vorlage erstellt.
Diese Vorlage als neues Projekt angelegt - sieht gut aus....
Morgen werde ich mal woanders online Publizieren und schauen ob die Seiten ok sind...
NOF 2015 - irgendwann begreife ich dich... Irgendwann!!!
Ich glaube, der Fehler sitzt vorm Bildschirm :-(
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  NOF 12, Seite lässt sich nicht hochladen Heidi 10 292 13.06.2019, 20:01
Letzter Beitrag: Heidi
  Lizenzschlüssel für NOF 12 geht nicht Wallace80 17 790 06.05.2019, 22:29
Letzter Beitrag: Wallace80
Exclamation NOF 12 läßt sich bei der Telekom nicht publizieren Spitzentrio 54 1.769 20.04.2019, 17:06
Letzter Beitrag: Spitzentrio
  Bilder anzeigen / nicht anzeigen lassen fantasiewelt 8 337 08.03.2019, 16:34
Letzter Beitrag: fantasiewelt
  SFTP Zugang funktioniert nicht nach Serverwechsel Kotamo 10 413 07.03.2019, 23:08
Letzter Beitrag: Martin73
  NOF 10 puplizierung funktioniert nicht Franzi 1 245 28.01.2019, 17:47
Letzter Beitrag: Wolfgang Z
  Newsbox mit jquery geht nicht mehr RB_BCC 24 1.049 22.12.2018, 15:57
Letzter Beitrag: Tommy Herrmann
  Page Overlay erstellen nintama 11 1.008 14.09.2018, 16:03
Letzter Beitrag: Tommy Herrmann
  Schrift wird in einigen Browsern nicht angezeigt wucki 3 546 22.08.2018, 16:47
Letzter Beitrag: Tommy Herrmann
  Mobi 4 - Bildanzeige wird nicht geändert struggle 11 1.428 26.06.2018, 19:56
Letzter Beitrag: struggle



Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
nach oben An den Anfang der Seite scrollen
NetObjects Fusion Infos, Downloads und Updates Diese Website wird durch Bot-Trap vor Spam geschützt!