Datenschutz Impressum

NOF-Schule | Forum

zur Schule NOF-NetObjects-Tutorials von Tommy Herrmann


Bilder Galerie am Liebsten per Link aufrufen aber auch Versteckt
#16
Hallo Thommy,

danke danke danke

hast du mal versucht ob bei dir der Effekt genau so ist wie bein mir
das er die Bilder übereinander legt??

Ich habe jetzt schon einmal absolute Pfade verwedet leider keine Änderung

Backstrecht raus genommen habe immer noch dne gleichen Effekt das er mit die Bilder übereinander legt.

Kannst du mal versuchen ob es bei dir genauso ist.

Ja ich sehe ja das es bei dir funktioniert ich bin dir so dankbar denn wenn ich
das hin bekomme dann bin ich 10 Schritte weiter

Danke
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#17
Moin,

der Fehler liegt an einem Konflikt zwischen den Lightbox- und Backstretch-JavaScripts.

Ich konnte das jetzt nachbauen.


.jpg  Backstretch.JPG (Größe: 183,3 KB / Downloads: 9)


Sobald das Hintergrundbild vom Lightbox-Skript erkannt wird, werden sich die anderen Bilder nicht mehr schließen und werden auf dem Hintergrundbild (was eben auch von der Lightbox erkannt wird, da diese alle Bilder erkennt) angezeigt.

Du kannst also nicht beides zusammen auf einer Seite verwenden Sad

Die Änderung im Skript auf die Bildformate hat bei mir auch nichts bewirkt, dennoch könntest Du das nochmals testen. Also für den Hintergrund ein Format wählen, dass Du im Skript entfernst:


.jpg  type.JPG (Größe: 47,19 KB / Downloads: 6)


.jpeg ging nicht

... versuche das "png" zu entfernen und das Hintergrundbild als .png zu verwenden. Mir war das dann aber bei der Dateigröße von 3MB zu groß. Müsste man dann noch anpassen, ich habe aber dazu gerade keine Zeit.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#18
... ich habe das jetzt nochmals mit einem .png Format für das Backstretch-Hintergrundbild versucht und dieses Format in der Zeile 58 in der Datei ...

imagelightbox.js

... ausgeschlossen.

Code:
allowedTypes:    'jpg|jpeg|gif',

Dann geht es.

Ich habe das auch auf meiner Seite nochmals beschrieben. Bitte meine Seite neu laden (Cache) - mit "Strg+F5" Tasten ...

http://www.mobirise-tutorials.com/Lawyer...float.html
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#19
Ich halte mich jetzt ja schon selbst für den Dümmsten Menschen
ich  hänge einfach immer noch
 
Ich habe jetzt den Backstrecht als .png gemacht
Habe PNG aus dem Jave Script sowieso schon entfernt da das auch unter NOF Schwierigkeiten gemacht hatte.
 
aber er legt bei mir immer noch die Seiten übereinander
 
Echtpfade habe ich euch genommen.
 
http://www.funsport-tarifa.com/GBT/page4.html
 
Ich habe immer noch den Effeckt das er mit die Seiten übereinander legt.
 
Dann habe ich das auf einer neuen Seite von meinen Versucht
 
http://www.funsport-tarifa.com/GBT/index.html
 
Immer noch der gleiche Effekt
 
Dann habe ich eine neue Seite erstellt
Jetzt geht es aber nicht
ich habe die Javer scripts rein Kopiert
Echt Pfade genommen
 
Davor hatte ich auch mit dem Java scrypten irgend welche Probleme wenn ich keine
Echtpfade genommen habe
 
Sorry Sorry aber auch hier wo nie Backstrecht drin war
Legt er mir die nur übereinander und ich bus refreshen damit er
mir die wieder sauber macht
 
Wo kann ich noch suchen
 
http://www.soltec-es.com/NOF-SCHULE/test190519/
 
Benutzername :  NOF-SCHULE
Paswort: NOF-1191
 
Ist ein neue Seite
 
Css ist eingefügt
Und Java
 
Die Dateien sind vorhanden
 
Echtpfade für die Bilder und Java was kann ich noch machen


Nur noch einmal ein neues Projekt machen mit einem Leeren Texblock
mit den Einstellungen von Thommy oder was bleibt mir sonst noch übrig?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#20
Moin,

Du - es ist doch einfach so - sobald Du irgend etwas anders gemacht haben solltest als ich, kann das passieren.

In Mobirise werden Hunderte von CSS-Klassen verwendet und schon ein anderer Block kann diesen Effekt nach sich ziehen.

Ich habe den ganz einfachen Textblock, den obersten unter "Articles", verwendet. Siehe Screnshot:


.jpg  Textblock.JPG (Größe: 438,86 KB / Downloads: 2)



Du solltest nochmals eine Testseite aufziehen und zunächst nichts anderes als diese Lightbox verwenden (kein "backstretch" und nichts).

Also dies CSS in den oberen Bereich "Inside <head> code" und die beiden Lightbox-Skripte in den Bereich "End of <body> code" (Du hast das doch bereits alles richtig gemacht) und dann irgendwo in den Textblock, am besten mitten in den Beispieltext rein kopierst Du mal den Code von meinem Bild hier:

Code:
<img src="http://www.mobirise-tutorials.com/LawyerM4-Tutorials/images/Spatz-Hinten.jpg" width="40%" alt="Bild" title="Spatzen">

Ich kann mir nur vorstellen, dass Du einen anderen Block verwendet hast, der vielleicht von Mobirise Eigenschaften mit sich bringt, die so nicht mit den anderen Skripten funktionieren.

Man muss da schrittweise vorgehen, sonst findet man so einen Fehler nie. Also immer eine Seite auf das Nötigste reduzieren und zunächst nur das einbauen, um das es geht. Erst dann macht man mit dem nächsten Skript (wie z.B. "backstretch") weiter, sonst weiß man doch gar nicht wo der Fehler liegen könnte.


P.S.:

bei Deinem Versuch, den Du mittels "htaccess" geschützt hast ist ein Fehler im Link zur ersten Datei. Da fehlen die Anführungsstriche vor dem http - die zweite Zeile ist richtig geschrieben.

Zitat:<script type="text/javascript" src=http://www.soltec-es.com/NOF-SCHULE/test190519/assets/imagelightbox.js"></script>

<script type="text/javascript" src="http://www.soltec-es.com/NOF-SCHULE/test190519/assets/nof-imagelightbox.js"></script>
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#21
Hallo Thommy,

ich weiß echt nicht
ich habe genau das gemacht
eine Leere Datei erstellt
Mit 2 von meinen Blöcken ging nicht
mit 2 Textblöcken
Wieder mit dem gleichen Ergebniss

http://www.soltec-es.com/NOF-SCHULE/test190520/

Danke das du dir soviel Mühe gibst

Benutzername :  NOF-SCHULE

Paswort: NOF-1191

Ich habe das nur in einem Gesicherten Bereicht gelegt damit ich nicht hinterher bei Goolge abgestraft werde wegen immer wiederholdenden Inhalten

Sorry wegen der Umstände ich weiß nicht warum ich mich so schwer tue
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#22
Das ist das Werk vom Teufel :eek:

... alles richtig bei Dir - warum geht es bei Dir nicht :eek:

Ich verwende eine neuere Mobirise-Version v4.10.1 - Du noch 4.9.7 - vielleicht liegt es daran (kann ich mir aber fast nicht vorstellen). Hier geht es zum Download:

https://mobirise.com/history.html


Da ich in meinem anderen Beispiel das Thema "LawyerM4" verwendet hatte, wollte ich sicherstellen, dass das im Standard Thema von "Mobirise 4" ebenso geht und habe das gerade erneut auf dieser Testseite eingebaut:

http://www.mobirise-tutorials.com/Testse...clone.html

Klicke auf den Spatz - der Block darunter ist ein unveränderter Galerie-Block von Mobirise, der eine eigene Lightbox eingebaut hat. Selbst die funktioniert noch und die Bilder von dieser Galerie werden nun zusätzlich auch noch in der eingebauten "Image-Lightbox" angezeigt.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#23
ich habe Deinen Fehler gefunden Smiling

Das "alt" Tag fehlt und das wird im Skript erwartet. Schreibe es z.B. so und es geht:

Code:
<img id="Bild" class="user_image1" src="http://www.soltec-es.com/NOF-SCHULE/test190520/assets/images/Metropolen-Hong-Kong.jpg" alt="Bild">

Das "alt" Tag wird in dem Text-Overlay (unten) als Text angezeigt - dieses Tag muss immer vorhanden sein!


.jpg  Overlay-Text.jpg (Größe: 553,77 KB / Downloads: 10)


Wenn man keinen Untertitel in Form dieses Overlays haben möchte, dann muss dennoch das Alt-Tag vorhanden sein und Du kannst es dann leer setzen, also so:

Code:
alt=""
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#24
Hallo Thommy du bist der Hammer wenn ich mal in Deutschland bei dir in der Nähe bin
darf ich dich dann auf ein Bier einladen oder wie kann ich das wieder gut machen

Dann noch eine Frage auch mit den Scrypten in den Head and Feet besser auch mit ganzem Pfad
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#25
Moin,

nein, das mit den ganzen (absoluten) Pfaden ist doch nur bei den Links zu den Bildern notwendig, alles andere kann mit relativen Pfaden sein, also auch die CSS im Head und auch die Skripte am Ende vom Body der Seite.

Gucke doch mal bei meiner Seite in den Quelltext (rechte Maustaste und im Kontextmenü wählen "Seitenquelltext oder Quellcode anzeigen").
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#26
Entschuldigung das ich das jetzt noch einmal Frage aber ich will es einfach nur genau wissen.

Ist das jetzt nur für diese Lösung oder ist es generell besser Bilder in Moibirse mit absoluten Pfaden ein zu fügen?

Und wenn warum?
Sorry wenn ich so hartnäckig bin aber ich will es ja auch nur ganz richtig machen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#27
Moin,

nein - generell ist es immer besser relative Pfade zu verwenden, so wie es eben auch Mobirise tut. Der Grund, wenn man z.B. seine Webseite mal auf eine andere Domain umzieht, bleiben die relativen Pfade ja gültig, absolute nicht.

Wenn man allerdings in Mobirise "eigene" Bilder in eigenen Skripten einbaut, dann "weiß" ja Mobirise davon nichts und sucht selbst angelegte, relative Pfade dann in seiner Projekt-Datei "project.mobirise".

Bilder die aber nicht über einen Block von Mobirise eingelesen wurden, wird Mobirise eben auch nicht in dieser Datei speichern und dann kommt es beim Publizieren zu einer Fehler-Meldung, da Mobirise alle Bilder mit relativen Pfadangaben mit den Einträgen in der Projekt-Datei vergleicht.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Bilder der Website von Mobirise werden nicht angezeigt nur der Text mobikfx750 48 2.996 Vor 3 Stunden
Letzter Beitrag: Steffen
  Bilder plötzlich langgezogen! stobi_de 2 74 28.05.2019, 15:03
Letzter Beitrag: stobi_de
  Mobi-Galerie-Close Button und Navik stobi_de 2 85 22.05.2019, 10:11
Letzter Beitrag: stobi_de
  Bilder fürs Smartphone stobi_de 10 179 19.05.2019, 17:33
Letzter Beitrag: stobi_de
  Bilder drehen in Mobirise UlfH 8 183 17.05.2019, 09:31
Letzter Beitrag: Tommy Herrmann
  Reihenfolge Bilder und Text im Handy stobi_de 2 99 07.05.2019, 20:14
Letzter Beitrag: stobi_de
  auch mal einen Dank an c-laus nof15us 6 261 11.04.2019, 23:45
Letzter Beitrag: barbara0701
  Link TITLE Attributen dj-acki 2 126 08.04.2019, 12:07
Letzter Beitrag: stobi_de
  LINK funkioniert nicht Peli45 8 267 04.04.2019, 21:48
Letzter Beitrag: Doris Rehhausen
  Fehler in der mobirise obboard-Galerie magfly78 3 165 28.03.2019, 11:12
Letzter Beitrag: magfly78



Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
nach oben An den Anfang der Seite scrollen
NetObjects Fusion Infos, Downloads und Updates Diese Website wird durch Bot-Trap vor Spam geschützt!