Datenschutz Impressum

NOF-Schule | Forum

zur Schule NOF-NetObjects-Tutorials von Tommy Herrmann

Die Foren sind geschlossen. Für Fragen zu MR, NOF & mehr steht Tommys Forum zur Verfügung. Ich danke für die langjährige Treue und Mitarbeit! Eure Administratorin.

Hilfe? Finde Ursache für den Zwischenraum nicht
#1
Hallo Leute,

ich finde einfach nicht meinen Fehler, könnt ihr mir bitte weiter helfen?
auf der Seite http://www.msm2016.de/test/index.html ist zwischen den Texten

"in Einöd, ..."
und
"die Sponsoren des MSM 2016 sind:"

ist dieser Zwischenraum und ich finde nicht die Ursache.
Es handelt sich um zwei Layoutbereiche, "in Einöd..." ist die letzte Zeile im oberen Layoutbereich und die Sponsoren sind im nächsten Layoutbereich (im Master). Layoutbereiche haben ein Hintergrundbild, das Layout selbst nur diese bläuliche Farbe.

Auf http://www.msm2016.de/test/historie.html (und auch auf keiner anderen Seite) habe ich das Problem nicht und ich kann es mir nicht erklären.

Ich bitte um Unterstützung. Danke.
Alle Beiträge dieses Benutzers finden
#2
Hallo Matthias,
Sieht so aus, als ob dir der untere Layoutbereich verrutscht ist. Kontrolliere doch mal in der Layoutansicht in deine Projekt, ob die wirklich ohne Abstand platziert sind.

Oder hast du die Laylutbereiche mittels css Classen formatiert? Dann hast du vielleicht irgendwo einen Margin (Außenabstand) definiert?
Alle Beiträge dieses Benutzers finden
#3
Sieht schon mal so aus, als ob die Position stimmt. Layoutbereich 4 hat Pos. Top 158px und ist 306 pixel hoch, macht zusammen 464. Layoutbereich 5 startet auf Position top 464 Pixel. Also keine Lücke. Das fällt schon mal weg. Ich überleg mal weiter...
Alle Beiträge dieses Benutzers finden
#4
Hallo Matthias,

In dem Layoutbereich ist ein "height: 303px" reingerutscht (CSS Eigenschaften mal schauen), wenn das raus ist, ist der Spalt weg Wink

Mit CSS Eintrag height: 303px;


.png  gernewitz1.PNG (Größe: 203,89 KB / Downloads: 40)


und ohne ...


.png  gernewitz2.PNG (Größe: 203,77 KB / Downloads: 43)
Alle Beiträge dieses Benutzers finden
#5
Danke, ich sehe es (wenn ich im NOF von der Design- auf die Code-Ansicht wechsle). Bringt mich aber zur nächsten Frage: da ich im NOF die Seiten erstelle und bearbeite, wie bekomme ich es da raus? Denn genau diese Zeile ist im Code deaktiviert, kann ich nicht direkt bearbeiten.
Oder muss ich das wirklich dann von außen mit einem Editor machen?
Alle Beiträge dieses Benutzers finden
#6
In den CSS Eigenschaften des Layoutbereiches "LayoutBereich4LYR" sollte der Wert von "height: 303px" stehen und sich löschen lassen.  thumbs up
Alle Beiträge dieses Benutzers finden
#7
Moin,

also die Höhe von einem Layoutbereich lässt sich nicht manuell ändern - sie wird immer so hoch angegeben, wie Du den Layoutbereich aufgezogen hast - jedoch wird diese nur bei einem dynamischen Layout festgelegt, da ist irgend etwas bei NOF schief gelaufen Sad

Ich habe das mal (in NOF 2015) nachgestellt und da funktioniert es eigentlich pixelgenau. Vielleicht ist da was falsch in Deinem NOF 12 generiert worden.

Du verwendest ja ein "festes" Seiten-Layout - HTML-Ausgabe "HTML 4.01" - und eigentlich sollte beim festen Seitenlayout (HTML 4.01) gar keine Höhe in dem DIV stehen, denn die Höhe wird ja oben bereits in der DIV-ID (oben als 'absolute' Style-Anweisung) festgelegt, nämlich 306px:

Zitat:div#LayoutBereich4LYR { position:absolute; top:158px; left:0px; width:990px; height:306px; z-index:3 }

... und genau dort entstehen die 3px Differenz, da in Deinem DIV eine Höhe von 303px angegeben ist, die dort bei "HTML 4.01" überhaupt nicht stehen dürfte.

Zitat:<div id="LayoutBereich4LYR" style="background-image: url('./assets/images/background_tb.png'); height: 303px;">

Ich würde Dir raten den "LayoutBereich4LYR" zu löschen und neu aufzuziehen.



P.S.:

... auf der Seite von Deinem 2. Beispiel (wo alles stimmt) ist im DIV auch, so wie es sein sollte, keine Höhe angegeben:

Zitat:<div id="LayoutBereich5LYR" style="background-image: url('./assets/images/background_tb.png');">
Alle Beiträge dieses Benutzers finden
#8
Danke für die Hilfe. Ja, ich habe es neu angelegt, dann ging es.
Alle Beiträge dieses Benutzers finden


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  PHP Fotoshow funzt nicht jh_elec 1 1.075 24.04.2020, 15:57
Letzter Beitrag: Tommy Herrmann
  Seiten nicht gleich angeordnet volpal 6 1.426 24.02.2020, 12:22
Letzter Beitrag: Rancher
  Assets werden bei Vorlage erstellen nicht gefunden EinDet 13 2.457 12.07.2019, 19:21
Letzter Beitrag: EinDet
  NOF 12, Seite lässt sich nicht hochladen Heidi 10 2.832 13.06.2019, 19:01
Letzter Beitrag: Heidi
  Lizenzschlüssel für NOF 12 geht nicht Wallace80 17 3.564 06.05.2019, 21:29
Letzter Beitrag: Wallace80
Exclamation NOF 12 läßt sich bei der Telekom nicht publizieren Spitzentrio 54 9.835 20.04.2019, 16:06
Letzter Beitrag: Spitzentrio
  Bilder anzeigen / nicht anzeigen lassen fantasiewelt 8 1.924 08.03.2019, 15:34
Letzter Beitrag: fantasiewelt
  SFTP Zugang funktioniert nicht nach Serverwechsel Kotamo 10 2.681 07.03.2019, 22:08
Letzter Beitrag: Martin73
  NOF 7.5 und NOF 9 - Hilfe Lunghb 22 3.754 02.03.2019, 05:41
Letzter Beitrag: Tommy Herrmann
  HILFE - Fehler beim Upload NOF 13 ossihessi 8 1.890 25.02.2019, 13:45
Letzter Beitrag: ossihessi



Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
nach oben An den Anfang der Seite scrollen
NetObjects Fusion Infos, Downloads und Updates Diese Website wird durch Bot-Trap vor Spam geschützt!