Datenschutz Impressum

NOF-Schule | Forum

zur Schule NOF-NetObjects-Tutorials von Tommy Herrmann


HTML Block und dann Layout Fehler
#1
Hallo User  :D

Immer wenn ich einen HTML Custom Block in ein fertiges Projekt einfüge, wird die Seite nicht mehr richtig angezeigt.

So sieht das Layout normalerweise aus


.png  webseite 2.png (Größe: 517,76 KB / Downloads: 23)



und so, sobald ein HTML Block drin ist


.png  webseite1.png (Größe: 49,33 KB / Downloads: 17)
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#2
Moin,

das ist nur ein "Platzhalter" (solange da noch nichts im Editor drinnen steht). Wenn da erst Code von Dir steht, wird das anders angezeigt.

... im Übrigen verwendet man diesen extra Block "Code Editor" doch eigentlich nie, sondern fügt seinen eigenen Code z.B. in einen einfachen Textblock an dem Block-Einstellungen am Symbol </> ein, wie z.B. hier auf meiner Gästebuch-Seite (unten) illustriert und beschrieben.

http://www.mobirise-tutorials.com/Gastbuch/gb.php
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#3
Tommy da hab ich wohl falsch ausgedrückt  :D

Mir ist das schon klar das ich da HTML Code rein mache - mache ich ja.
Aber mir geht es um die CSS, das farbliche Layout.

Sobald ich die Seite als PHP speicher ist das weg, obwohl Assets hochgeladen wurden und Browser cache gelöscht wurde.

Deswegen gehe ich den Umweg mit Iframe und speicher alles als HTML, da geht es ja.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#4
das sollte nicht sein und das ist bei mir auch nicht so.

Keine Ahnung, was Du da gerade falsch machen könntest. Verwendest Du dabei noch eine externe CSS? Du musst aufpassen, dass Du keine <body> Styles veränderst oder mit einer eigenen CSS überschreibst.

CSS, die Du vielleicht in den "Code Editor" in den Bereich "CSS Editor" einträgst, steht als letztes in der CSS-Hierarchie und ist deswegen vorrangig.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#5
(30.11.2019, 08:27)Tommy Herrmann schrieb: Du musst aufpassen, dass Du keine <body> Styles veränderst oder mit einer eigenen CSS überschreibst.


Das ist es !!  thumbs up

<body>  der böse body 
Danke Tommy
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  TAB Block um einen Punkt erweitern funsport 5 169 01.06.2020, 19:54
Letzter Beitrag: Martin73
  Fehler Mobirise 4 Datenschutzerkärung wird angezeigt Michael G 8 199 27.05.2020, 10:05
Letzter Beitrag: Tommy Herrmann
  Fehler bei der Anmeldung - Anmeldung klappt nicht Utz29 13 223 21.04.2020, 08:49
Letzter Beitrag: Tommy Herrmann
  Dem Block aus Slider Galeries eine Schatten verpassen funsport 6 226 06.04.2020, 21:47
Letzter Beitrag: Martin73
  Hintergrundfarbe Block Radi 3 202 25.03.2020, 14:57
Letzter Beitrag: Tommy Herrmann
  Block zerhauen nach gebrauch von TAB Taste funsport 1 143 16.03.2020, 09:43
Letzter Beitrag: Tommy Herrmann
  font im Mobirise Block ändern nof15us 2 255 03.03.2020, 14:08
Letzter Beitrag: nof15us
  HTML Code einfügen soeren2512 1 159 28.02.2020, 07:11
Letzter Beitrag: Tommy Herrmann
  Sprachangabe <html lang="de-DE"> stobi_de 6 333 25.02.2020, 07:56
Letzter Beitrag: Tommy Herrmann
  Test-Datei zur Eingabe von PHP, CSS, JS, HTML Goldschwalbe 10 385 25.02.2020, 07:10
Letzter Beitrag: Goldschwalbe



Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
nach oben An den Anfang der Seite scrollen
NetObjects Fusion Infos, Downloads und Updates Diese Website wird durch Bot-Trap vor Spam geschützt!