Datenschutz Impressum

NOF-Schule | Forum

zur Schule NOF-NetObjects-Tutorials von Tommy Herrmann

Die Foren sind geschlossen. Für Fragen zu MR, NOF & mehr steht Tommys Forum zur Verfügung. Ich danke für die langjährige Treue und Mitarbeit! Eure Administratorin.

Mobirise // Eigenes Mailscript funzt nicht mehr auf PHP 7.2
#1
Hallo zusammen,

ich verwende ein eigenes Mailscript für den Versand bei Mobirise.
http://www.mobirise-tutorials.com/Kontakt-Formular.php
Leider funzt es bei PHP 7.2 nicht mehr. Stelle ich auf 5.3 läuft alles.
Wer kann mir helfen.
Danke!!!
Alle Beiträge dieses Benutzers finden
#2
Moin,

... ich hatte gerade auf Deine Mail an mich geantwortet.

Ich habe das Script auf dieser, meiner Seite gerade eben nochmals getestet:

http://www.mobirise-tutorials.com/Kontakt-Formular.php

... und es läuft einwandfrei bei mir mit sogar PHP 7.4.7:

http://www.mobirise-tutorials.com/PHP/

... und die Mail kommt ebenfalls einwandfrei bei mir an.

Ich denke mal der Fehler liegt dann irgendwo bei Dir und nicht am Script und auch nicht an PHP 7.2.

Vielleicht liest das ja Werner hier und hat als Autor von diesem Script eine Idee woran das Problem bei Dir liegen könnte.
Alle Beiträge dieses Benutzers finden
#3
Das wäre die Fehlermeldung die ich bekommen!

Fatal error: require(): Failed opening required 'PHPMailer-5.2-stable/PHPMailerAutoload.php' (include_path='.:/usr/lib/php7.2') in /homepages/19/d814830935/htdocs/beta20/mailscript-notfall.php on line 31

Danke Tommy für die Mail, habe ich bekommen.
Liebe Grüße
Alle Beiträge dieses Benutzers finden
#4
Hier Deine Fehlermeldung (u.a. für Werner):

Zitat:Fatal error: require(): Failed opening required 'PHPMailer-5.2-stable/PHPMailerAutoload.php' (include_path='.:/usr/lib/php7.2')



Ich vermute eine falsche Pfadangabe, das Verzeichnis "PHPMailer-5.2-stable" mit allen PHPMailer-Skripten muss in der Root Deines Projektes liegen und auch so heißen - so wurde es zumindest vom Werner in seinem Skript "mailscript.php", das dann ebenfalls im gleichen Verzeichnis liegen muss, geschrieben:

PHP-Code:
require "PHPMailer-5.2-stable/PHPMailerAutoload.php"

... oder versuchst Du das aus einem Testverzeichnis "beta20", das an anderer Stelle liegt, zu verwenden? Das geht so nicht.
Alle Beiträge dieses Benutzers finden
#5
Sollte also das neue Verzeichnis "beta20" das neue "Root-Verzeichnis" Deines neuen Projektes sein, dann müsstest Du das gesamte Verzeichnis "PHPMailer-5.2-stable" und auch die Datei "mailscript.php" in dieses neue Verzeichnis "beta20" kopieren.
Alle Beiträge dieses Benutzers finden
#6
Smile 
... du hast recht, wenn es im ROOT liegt läuft alles!
Besten Dank für die schnelle Hilfe.
Viele Grüße
Alle Beiträge dieses Benutzers finden


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Umstieg auf Mobirise 5 nof15us 67 3.354 16.12.2020, 10:53
Letzter Beitrag: Tommy Herrmann
  NOF 12 und Mobirise kombinieren Petergun 14 398 11.12.2020, 07:50
Letzter Beitrag: Petergun
  Mobirise-MP3 Player einbinden. Soundcloud? Thomas Saake 11 369 08.12.2020, 17:16
Letzter Beitrag: Thomas Saake
  Mobirise-Drop Down Menü verschiedene Farben Thomas Saake 8 229 08.12.2020, 14:42
Letzter Beitrag: Thomas Saake
  Mobirise-Text unter Logo Menüleiste Thomas Saake 14 421 03.12.2020, 17:22
Letzter Beitrag: Thomas Saake
  Mobirise-Noch ein Problem mit Hamburger Menü auf Handy Thomas Saake 23 529 30.11.2020, 16:54
Letzter Beitrag: Thomas Saake
  Mobirise-PopUp Modal Text statt Kreuz zum schließen Thomas Saake 3 169 26.11.2020, 15:43
Letzter Beitrag: Thomas Saake
  Mobirise-Timeline Abstand verringern Thomas Saake 2 117 26.11.2020, 14:10
Letzter Beitrag: Thomas Saake
  Icon wird nicht angezeigt kfz-fotograf 7 226 25.11.2020, 14:15
Letzter Beitrag: barbara0701
  Position Icons - Mobirise 5.2.0. Markus78 9 341 16.11.2020, 19:03
Letzter Beitrag: Tommy Herrmann



Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
nach oben An den Anfang der Seite scrollen
NetObjects Fusion Infos, Downloads und Updates Diese Website wird durch Bot-Trap vor Spam geschützt!