Datenschutz Impressum

NOF-Schule | Forum

zur Schule NOF-NetObjects-Tutorials von Tommy Herrmann


PHP 7.2 o.ä.
#1
Hallo zusammen,
mein Provider (Strato) habe mich aufgefordert von PHP 5.6 auf PHP 7.2 umzustellen. Nachdem ich dies problemlos durchgeführt habe, kommt man nicht mehr auf die gesicherten Seiten. Jetzt würde ich gerne wieder auf das alte System PHP 5.6 zurückwechseln, aber das geht bei Strato nicht.
Wer kann mir weiterhelfen, dass die sicheren Seiten wieder genutzt werden können.
Die Fehlermeldung anbei:

"[Fehler 602] XML-Fehler. SecureSite-Komponenten sind über Datenbankpfad 'S' nicht auffindbar. Möglicherweise handelt es sich um einen Publishing-Fehler. Wenn der Fehler durch eine erneute Veröffentlichung der Site nicht behoben wird, wenden Sie sich an den Technischen Support und geben Sie diese Informationen an."

Vorab vielen Dank für die Hilfe.
MfG - Holger
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#2
Moin,

Du solltest eigentlich wieder auf 5.6 zurückstellen können :eek:

Das nutzt dann aber nur temporär etwas, denn irgendwann wird diese PHP-Version eingestellt.

NOF ist total veraltet und die PHP-Komponenten arbeiten nicht mehr mit neueren PHP-Versionen. Im Prinzip war da schon bei PHP 5.4 Schluss.

Da kann Dir niemand helfen - da müssten die PHP-Skripte von NOF neu geschrieben werden.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#3
Grundsätzlich hat Tommy erstmal Recht  :D  die Skripte von NOF sind mausealt.

Strato hat dir sicher per Email vor längerer Zeit mitgeteilt, das du "STRATO PHP Extended Support" in Zukunft für die alten PHP Versionen verwenden solltest.

Am besten ist es, sich mit Strato mal in Verbindung zu setzen.  thumbs up
mfg.
|---------------------------------
|Glück ist ... kein Pech zu haben.
|---------------------------------
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#4
Hallo,
besteht eigentlich die Möglichkeit eine umfangreich mit NOF 2015 erstellte Website (www.tpo-online.de) in ein anderes Programm, wie z.B. Dreamweaver o.ä., zu konvertieren?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#5
Moin,

nein - das wird nicht gehen oder nur sehr bedingt. Schon der Quelltext von NOF ist ja urtümlich alt und wird so in keinem modernen Programm übernommen werden können.

Die ganzen Links zu den JavaScript- und CSS-Dateien gehen dann sowieso nicht mehr.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#6
Guten Morgen, ich habe auch von Strato den Support angeboten bekommen. Mich wundert nur, ich habe die Mehrzahl meiner Websites mit Mobirise gemacht und wenn ich die php Version abfrage, bekomme ich immer 5.6... angezeigt.

Beispiel :

.: EDIT Tommy :.

Link gelöscht


mfg
R. beer
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#7
Moin,

die PHP-Version musst Du selbst (aktiv) im Kundenmenü vom Provider einstellen. Dort stehen einem ca. 3 Versionen zur Verfügung, die gerade verwendete, die aktuell empfohlene und die neueste.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#8
PHP ist ein serverseitiges Script, das heißt: Der Server verarbeitet, was Du ihm anbietest! Mobirise verwendet meines Wissens kein php. Ich kenne allerdings nicht alle Templates! Das PHP setzt der User ein.
Keine Zeit, muss Haare machen!
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#9
... das hat jetzt aber nichts mit Mobirise zu tun. Mobirise verwendet selbst (z.Zt.) keinerlei PHP-Skripte, man kann doch aber solche jederzeit auch in Mobirise integrieren.

Ich habe Dutzende von PHP-Anwendungen in Mobirise eingebaut, wie z.B. mein persönliches Formular.

... und welche Software Du nun verwendest (wie z.B. 'Mobirise' oder 'NOF') ist doch dem Provider vollkommen egal. Die dort verwendete PHP-Version wird vom Provider angeboten, egal ob man die nun benötigt oder nicht.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#10
... die Einstellungen für die PHP-Version findest du bei Strato hier:


.jpg  strato_php.JPG (Größe: 98,06 KB / Downloads: 8)
mfg.
|---------------------------------
|Glück ist ... kein Pech zu haben.
|---------------------------------
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#11
Meine wohl falsche Annahme, ich dachte mit der info.php bekomme ich die Information welche php Version in meinen Scripts steckt ohne dass ich die Scripts nochmal einzeln prüfen muß.
Wenn Mobirise keine php Scripte verwendet, dann habe ich nur die Scripte von Tommy bzw. Werner Zenk. Da steht im PHP 5.4+ drin. Also müßte ich den 5 Euro Service von Strato annehmen?

mfg
R. Beer
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#12
Die php-info gibt dir die Auskunft über deine aktuell verwendete php-Version Serverseitig!
Willst du da etwas ändern auf eine neue und damit aktuelle Version, musst du wohl das Strato-Angebot annehmen.
In den Skripten von werner oder Tommy (oder wer noch :D ) ist die "niedrigste" (PHP 5.4+) funktionierende Version angegeben thumbs up
mfg.
|---------------------------------
|Glück ist ... kein Pech zu haben.
|---------------------------------
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#13
... richtig - die Skripte vom Werner funktionieren alle auch mit PHP 7.2 und höher
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#14
Guten Tag "immergut", bezahlt werden muss die 5.... Version, die Versionen 7.. sind ja kostenfrei.

Danke Allen für die Informationen
R. Beer
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#15
Genau ... für die "Alte" musste auch noch zahlen :D thumbs up
mfg.
|---------------------------------
|Glück ist ... kein Pech zu haben.
|---------------------------------
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren




Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
nach oben An den Anfang der Seite scrollen
NetObjects Fusion Infos, Downloads und Updates Diese Website wird durch Bot-Trap vor Spam geschützt!