Datenschutz Impressum

NOF-Schule | Forum

zur Schule NOF-NetObjects-Tutorials von Tommy Herrmann

Die Foren sind geschlossen. Für Fragen zu MR, NOF & mehr steht Tommys Forum zur Verfügung. Ich danke für die langjährige Treue und Mitarbeit! Eure Administratorin.

Publizierung funktioniert nicht richtig
#46
1. Heisst das Verzeichnis Test oder test? (Groß-/Kleinschreibung beachten)
2. Bei Verzeichnis muss ein / davor.
Alle Beiträge dieses Benutzers finden
#47
Hallo khwerner,

bevor an eine Publizierung überhaupt gedacht werden kann, muss eine Verbindung
zum Server klappen.
Und die ist momentan nicht gegeben ! ! ! Exclamation

Also stimmt bei den Publizierungseinstellungen was nicht.
Da gibt es so einiges zu beachten:
- keine Leerzeichen (blanks); auch nicht nach dem Paßwort
- Groß.-Kleinschreibung ist zu beachten

Erst wenn die Verbindung zum Server positiv ist, können die Daten
überhaupt zum Server übertragen/publiziert werden. Exclamation
Alle Beiträge dieses Benutzers finden
#48
@ Rancher, das Verzeichnis heist Test s. Screenshot (ich hoff ich hab das mit dem Testordner richtig gemacht)

.jpg  Testordner im 1+1 Webspace.jpg (Größe: 86,11 KB / Downloads: 15)


ich hab auch ein / beri Einstellungen davor gemacht s. Screenshot

.jpg  Test bei Publizierung.jpg (Größe: 83,42 KB / Downloads: 20)


@WolfgangZ
hab alles so wie bei 1+1 angegeben in die Einstellungen bei NOF reinkopiert u. aif Groß-Kleinschreibung u. Leerzeichen geachtet. s. Screen oben

Anbei noch einpaar die ich von 1+1 gemacht habe

.jpg  Einstellungen bei 1+1 Domains.jpg (Größe: 67,7 KB / Downloads: 17)



.jpg  Sichere FTP Zugänge verwalten.jpg (Größe: 68,88 KB / Downloads: 12)


Warum bei Sichere FTP-Zugänge Verzeichnis /. steht u. bei Domains & SSL nur / ohne Punkt steht weis ich leider nicht.
Fakt ist aber dass offensichtlich keine Verbindung für eine besteht.
Ich glaub fast immer noch dass 1+1 alte Verträge durch neue Produkte ersetzt haben will.
Alle Beiträge dieses Benutzers finden
#49
... also eigentlich kann ja nur noch ein Fehler im Passwort sein :confused:

Da das Verzeichnis "Test" auch am Server im Stammverzeichnis liegt, braucht da nur stehen:

Test

... allenfalls kannst Du auch schreiben:

Test/

... das habe ich jetzt aber schon einige mal geschrieben. Alles andere ist falsch.

Dann würde ich mal die "Live URL" entweder entfernen oder eben auch das sichere Protokoll "https" verwenden und nicht "http".

Kontrolliere auch nochmals am Button "Erweitert" (hinter dem Servertyp), ob dort der Port: 22 angegeben ist.

Du kannst das Feld "Verzeichnis" auch ganz leer setzen, dennoch müsste ja dann am Button "Test" die Verbindung zum Server hergestellt werden. Wird sie das nicht, ist irgend etwas falsch eingetragen - vielleicht das Passwort?!!

Beim Passwort musst Du zwingend auf Groß- und Kleinschreibung achten. Zur Not würde ich mal bei 1und1 ein neues Passwort angeben und anschließend dann in NOF dieses neue Passwort versuchen.
Alle Beiträge dieses Benutzers finden
#50
@ Tommy Herrmann
Bei Passwort muss doch das PW rein mit dem ich mich bei 1+1 anmelde oder gibt es da noch ein anderes?
Ansonsten hab ich alles so eingegeben wie du mir geschrieben hast Auch Serverport 22

.jpg  Publizierungseinstellungen NOF bei druck auf Test.jpg (Größe: 125,56 KB / Downloads: 19)
Alle Beiträge dieses Benutzers finden
#51
NEIN - das ist das sogenannte FTP-Passwort - das ist immer ein anderes
Alle Beiträge dieses Benutzers finden
#52
Gehe im Kunden-Center von 1und1:

> Rubrik "Hosting"

> SFTP & SSH

> Klicke auf das Zahnrad neben Deinem Haupt-Benutzernamen (Einstellungen bearbeiten)

> Klicke auf > bei "Passwort"


.jpg  Passwort.JPG (Größe: 60,22 KB / Downloads: 9)


> Vergebe ein neues Passwort (das ist nur für Dich) für Deinen FTP-Zugang. Schreibe es Dir gut auf. Keine Leer- oder Sonderzeichen (keine Umlaute) verwenden!

> Trage das neue Passwort in NOF ein und alles ist gut.

Dieses Passwort gilt dann für alle FTP-Zugänge, also z.B. auch für ein externes FTP-Programm wie "FileZilla".
Alle Beiträge dieses Benutzers finden
#53
leider wars nix. Hab alles so gemacht mit dem PW, aber siehe Screenshot


.jpg  Fernpublizierung NOF-Fehler.jpg (Größe: 57,83 KB / Downloads: 23)
Alle Beiträge dieses Benutzers finden
#54
versuche doch einmal spaßeshalber statt SFTP den FTP auszuwählen.

P.S. ich habe zwar noch nie aus NOF heraus hochgeladen, habe es aber eben erstmals nachgestellt. Funktioniert auf Anhieb.
Habe leider auch keinen Plan, warum es bei Dir nicht funktioniert.
Alle Beiträge dieses Benutzers finden
#55
(20.01.2019, 12:41)coco schrieb: versuche doch einmal spaßeshalber statt SFTP  den FTP auszuwählen.

P.S. ich habe zwar noch nie aus NOF heraus hochgeladen, habe es aber eben erstmals nachgestellt. Funktioniert auf Anhieb.
Habe leider auch keinen Plan, warum es bei Dir nicht funktioniert.

Hallo,
dein Tip hat glaube ich funktioniert nur kommt jetzt nach derm Hinweis dass die Seite publiziert wird folgende Fehlermeldung:


.jpg  Verbindungsprobleme.jpg (Größe: 49,06 KB / Downloads: 11)
Alle Beiträge dieses Benutzers finden
#56
Moin,

also in Deinem letzten Screenshot zeigst Du einen ganz anderen Profilnamen - nämlich:

"TSG - Fernpublizierung"

Was machst Du überhaupt auf dieser NOF-Seite, dort publiziert man doch nicht :eek:

Keine Ahnung was nun dahinter für eine Konfiguration steckt. Zuletzt hast Du in Deinem Beitrag #50 diesen Profilnamen gezeigt:

"TSG Waldbüttelbrunn fern"

Dort sehen die Einstellungen doch richtig aus (hast Du das neue Passwort eingetragen?). Dort wird entfernt publiziert. Drücke dort auf den Button "Test" !!!


.jpg  Publizierungseinstellungen.jpg (Größe: 277,08 KB / Downloads: 11)


Du kannst nicht die eine Profileinstellung ändern und dann mit einem anderen (unveränderten) Profil Deine Tests machen :eek:


Sollte es daran auch nicht liegen, dann fällt mir auch nichts mehr ein. Wirklich viel falsch machen kann man da doch gar nicht :confused:

Hast Du denn mit dem externen FTP-Programm "FileZilla" die gleichen Probleme?

Du solltest vielleicht mal am Montag bei 1und1 anrufen und sie fragen, was Du da falsch machen könntest. Außer Deinem Passwort können sie ja Deine Daten alle sehen und Dir z.B. auch genau erklären, was Du wo bei "FileZilla" eintragen müsstest.

Bei NOF sind dann die Einträge identisch.
Alle Beiträge dieses Benutzers finden
#57
Hast du einen Linux oder Windows Serverplatz bei 1&1?
Ich hatte mal einen Kunden mit Windows Server. Da klappte die Publizierung über NOF auch nicht.
Alle Beiträge dieses Benutzers finden
#58
(20.01.2019, 13:18)Tommy Herrmann schrieb: Moin,

also in Deinem letzten Screenshot zeigst Du einen ganz anderen Profilnamen - nämlich:

"TSG - Fernpublizierung"

Was machst Du überhaupt auf dieser NOF-Seite, dort publiziert man doch nicht :eek:

Keine Ahnung was nun dahinter für eine Konfiguration steckt. Zuletzt hast Du in Deinem Beitrag #50 diesen Profilnamen gezeigt:

"TSG Waldbüttelbrunn fern"

Dort sehen die Einstellungen doch richtig aus (hast Du das neue Passwort eingetragen?). Dort wird entfernt publiziert. Drücke dort auf den Button "Test" !!!



Du kannst nicht die eine Profileinstellung ändern und dann mit einem anderen (unveränderten) Profil Deine Tests machen :eek:


Sollte es daran auch nicht liegen, dann fällt mir auch nichts mehr ein. Wirklich viel falsch machen kann man da doch gar nicht :confused:

Hast Du denn mit dem externen FTP-Programm "FileZilla" die gleichen Probleme?

Du solltest vielleicht mal am Montag bei 1und1 anrufen und sie fragen, was Du da falsch machen könntest. Außer Deinem Passwort können sie ja Deine Daten alle sehen und Dir z.B. auch genau erklären, was Du wo bei "FileZilla" eintragen müsstest.

Bei NOF sind dann die Einträge identisch.

Bei erweiterte SFTP muss zwingend port 22 eingestellt werden, macht nof aber eigentlich automatisch, zumindest bei mir.
Alle Beiträge dieses Benutzers finden
#59
….lösche einmal die Live-URL in den Einstellungen
Alle Beiträge dieses Benutzers finden
#60
Hi,
also nach dem Löschen der LiveURL hat die Publizierung funktioniert. Nur ist die von mir gemachte Änderung nicht ersichtlich. Offenbar wird eine andere Seite publiziert u. nicht die die ich geändert habe.
Ich denke jetzt muss erstmal das Stammverzeichnis bei 1+1 aufgeräumt werden so dass nur die notwendigen Ordner noch da sind (so wie Tommy in seinem Beitrag v. 16.01.19 mitgeteilt hat). Nur wo u. wie kann ich diese löschen?
@Doris > ob ich einen Linux oder Windows Serverplatz habe weis ich nicht, weis auch nicht woran ich das erkennen kann. Ich jedenfalls hab Win 10 auf meinem PC.
@ Tommy > ich hab bisher immer mit NOF publiziert u. nie Probleme gehabt. Erst seit Umstellung zu IONOS u. der Einrichtung von SSL (die mir ein 1+1 Mitarbeiter tel. geraten hat) habe ich das Problem mit dem Publizieren gemerkt.
Wie FileZilla funktioniert oder ob dies einfacher geht weis ich leider nicht.


.jpg  Startseite NOV.jpg (Größe: 110,57 KB / Downloads: 7)


TSG Waldbüttelbrunn ist die normale Seite die ich auch weiterhin pflegen will.
TSG Waldbüttelbrunn1 ist die aus einer Vorlage neu eingefügte Seite die zum Testen war.
Fussball ist die Seite die ich angelegt habe die aber z.Zt. still steht u. nur noch zur Info existiert aber nicht mehr laufend aktualisiert wird.

Wenn ich zur weiteren Hilfe Screenshots hochladen soll bitte melden. danke
Alle Beiträge dieses Benutzers finden


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Absturz bei Publizierung lokal + online firehead 2 1.410 04.11.2019, 18:05
Letzter Beitrag: c-laus
  NOF 12 Update 4 lässt sich nicht installieren thommy1820 7 1.411 26.10.2019, 18:26
Letzter Beitrag: Rancher
  NOF 10 puplizierung funktioniert nicht Franzi 23 4.474 21.02.2019, 17:21
Letzter Beitrag: Rancher
  Seiteneigenschaft nicht sichtbar rolf0442 4 1.655 19.02.2019, 10:51
Letzter Beitrag: rolf0442
Rainbow Falscher Seiteninhalt und Lokale Publizierung Klara 18 3.953 15.09.2018, 17:50
Letzter Beitrag: Hansi151
  HP-Hauptseite öffnet sich nicht mehr aroundtheworld 21 7.383 15.04.2018, 21:37
Letzter Beitrag: barbara0701
  Publizierung fehlerhaft - Fotos nicht hochgeladen seejungfrauxs 8 3.242 16.11.2017, 17:48
Letzter Beitrag: Tommy Herrmann
  NOF funktioniert nicht - Checkliste barbara0701 0 4.007 15.03.2015, 11:47
Letzter Beitrag: barbara0701
  Wie installiere ich NOF richtig? (VISTA/WINDOWS7, WIN8 etc) barbara0701 3 18.049 31.10.2013, 16:14
Letzter Beitrag: Dozi
  Beschreibung Publizierung nach Site-Struktur barbara0701 0 4.086 04.06.2013, 16:54
Letzter Beitrag: barbara0701



Benutzer, die gerade dieses Thema anschauen: 3 Gast/Gäste
nach oben An den Anfang der Seite scrollen
NetObjects Fusion Infos, Downloads und Updates Diese Website wird durch Bot-Trap vor Spam geschützt!