Datenschutz Impressum

NOF-Schule | Forum

zur Schule NOF-NetObjects-Tutorials von Tommy Herrmann


Seo: CSS und Javascript optimieren - Wie?
#1
Nachdem ich mich nun endlich wieder einloggen kann, möchte ich eine Frage loswerden, die mich schon seit Tagen quählt.

Ich versuche mich nun an Seo- und Pagespeedoptimierungen, was auch gut klappt. Testweise hab ich sehr gute Werte erreicht.

Ich bekomme zwar auf der Indexseite alles perfekt zum laufen, dafür funktioniert alles dahinter auf den anderen Seiten gar nichts mehr, obwohl dort noch die links zu den Original CSS- und Javadateien stehen. Auch die zusammengefassten Daten funktionieren dort nicht. Einfach mergen klappt also nicht richtig.

Die Frage wie kann ich bei Mobirise die CSS und Javascript-Dateien zusammenfassen? bzw optimieren, damit sie auf der ganzen Seite Global funktionieren. Es sind einfach zu viele Dateien für wirkungsvolle Optimierungen.


Es gibt zwar php-Scripte im Netz, die funktionieren aber auch nicht.


Bin nun mit meinem Latein am ende. Wer kann helfen?

Lg.
Chris
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#2
Moin Chris,

nee Du, da sehe ich so keine Möglichkeit. Ich glaube auch, dass die Geschwindigkeit, die man dadurch sparen könnte, eher nicht messbar ist :eek:

Je nachdem, was man für Erweiterungen installiert hat, werden ja immer mehr CSS-Dateien geladen. Z.B. für die Icons, den "WOW-Slider" oder Paypal und Dutzende anderer Dinge, die dann vielleicht auch viel später irgendwann dazu kommen.

Das alles wird vom Programm generiert und das kannst Du so nicht beeinflussen - sollest Du auch nicht - denn gerade die CSS- und JavaScriptdateien von irgendwelchen Themen/Blöcken werden bei fast jedem Update von Mobirise geändert.

Hier mal nur ein kleiner Teil der CSS-Dateien, die da eventuell notwendig werden - das können noch viel mehr werden.


.jpg  CSS-Dateien_Mobirise.JPG (Größe: 138,79 KB / Downloads: 7)


P.S.:

Man sollte solche CSS-Dateien sowieso nicht zusammenfügen. Das macht doch überhaupt keinen Sinn, dadurch wird der Browser doch nicht schneller :eek:

Es macht dagegen sehr viel Sinn für die unterschiedlichen Anwendungen eigene CSS-Dateien zu haben.

Da gibt es z.B die ganz wichtigen Dateien vom "Bootstrap" Framework - die sollte man auf keinen Fall irgendwo mit dazu tun, das ist jetzt Version 4.0 und bald wird Mobirise sicherlich auf v4.1 updaten.

Dann gibt es eine eigene CSS-Datei, die ausschließlich die CSS der verwendetet Blöcke beinhaltet und auch eben die User-Änderungen. Diese Datei muss immer als letzte CSS-Datei geladen werden. Da gibt es irre viele Dinge zu beachten und mit Deinem Vorhaben würdest Du wahrscheinlich eher alles zerstören und eine Fehler-Analyse unmöglich machen.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#3
Moin,

irgendwie raff ich das nicht ganz genau, zu viele Fragen :confused: auf einmal
Kannst du das denn nicht mal zeigen (Link) damit man sich ein Bild machen kann.
So auf Verdacht z antworten, hilft ja keinem.
Bis denne, C-laus

WIN 10/Alle Browser/AdobePhotoshop/
NOF15/Mobirise 3+4, alle Templates/Kaspersky
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#4
Wenn Du ein Optimierungsproblem auf Unterseiten hast liegt es bestimmt nicht an den css-Dateien. Das müsste man sich anschauen.
Lieben Gruß
Barbara
--------------
Lumis-Webdesign
Umwelt und Meere schonen: Plastikmüll vermeiden!
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#5
Ja, ich befürchte auch das das so nichts wird.Hatte noch Hoffnung das es jemand gelöst hat.

Wollte einfach nur den Pagespeed weiter optimieren.

Im Moment scheint Mobirise M4 Probleme zu haben. So richtig Responsive ist es nicht.
Mit dem Tablet kann ich nicht mal die Navigation anklicken und auf dem Telefon passen die Bilder nicht richtig. Quasi nutzlos das ganze.

Und keine der Bildergalerien die ich getestet habe funtktioniert. Die aufgerufenen Bilder erscheinen alle unten am Rand des Browsers oder gar nicht. Gruselig... Aber ne andere Baustelle.

Lg.
Chris
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#6
Chris,

was Du jetzt schreibst ist vollkommen daneben. Mobirise ist zu 100% responsive und auch die Navi funktioniert am Handy oder sonstwo.

Tut es das bei Dir nicht, dann hast Du bereits mit Deinen Versuchen CSS vernichtet ...
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#7
Moin

da möchte ich aber ganz vehement widersprechen.
Mobirise ist voll responsiv, in jeder Beziehung. Wenn du der Meinung bist,
das ist alles Müll oder funktioniert nicht richtig, dann liegt das Problem nicht in der Mobi-Software, sondern beim User, denn der muss das umsetzen,was Mobi bietet und kann.

Wenn du da noch nicht so fit bist, das nicht umsetzen kannst,dann solltest du etwas üben und testen, bevor du zum Rund-Um-Kahlschlag ausholst...und wenn du dann noch ein Problem mit irgendetwas hast, dann fragst du hier gezielt und dir wird geholfen.

Und wenn das auch nicht hilft...dann nutze das hier

.jpg  img023.jpg (Größe: 295,67 KB / Downloads: 6)


oder lasse deine Website bauen

Alles Klaro? Prima!
Bis denne, C-laus

WIN 10/Alle Browser/AdobePhotoshop/
NOF15/Mobirise 3+4, alle Templates/Kaspersky
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#8
Da widerspreche ich aber auch :D 

Eure Hilfe nehm ich gerne. Ist ja auch Gold Wert. thumbs up

Hab das ganze Projekt gelöscht und komplett neu hochgespielt um Altdaten auszuschließen.
Ich weiß, das man sich manchmal selbst im Weg steht. Aber das garnix geht, kenn ich so nicht.
Wer mal schauen möchte: Link
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#9
Moin,

ich habe geschaut. Und nun?
Mal abgesehen vom Design/Optik, was bemängelst du denn nun genau?

...das hier, das schmeiß mal zuerst raus. (Siehe Quelltext-rot)

<html xmlns="http://www.w3.org/1999/xhtml" lang="de" xml:lang="de">

<!DOCTYPE html>
<html >
Bis denne, C-laus

WIN 10/Alle Browser/AdobePhotoshop/
NOF15/Mobirise 3+4, alle Templates/Kaspersky
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#10
@Saghon: Du hast ein Menü-problem. Hatte sich in Version 4.4.irgendwas eingeschlichen.
Du benutzt warscheinlich das Agency-Menü in einem anderen Theme.
ich weiß nicht, ob sich das mit den aktuellen Updates noch beißt, aber bis vor einigen Wochen war das der Fall.

Benutze das Menü aus dem von Dir benutzen Theme und alles wird gut.
Fummel nicht zu sehr an den Mobi-css-Dateien rum. Das nehmen die übel.

Dein Design schreit jetzt auch nicht danach, irgendwelche Menüs von anderen Themes zu nutzen.

Wenn Du für Google optimieren willst, so würde ich nicht am unwichtigsten Punkt anfangen.
Du verschenkst alle Alt-Texte von Bildern an unwichtige Bezeichnungen (Wappen, Plakette,...)
Die ganzen OG-Tags fehlen
Die Seitennamen sind unbrauchbar (page1, page2...)

Gruß
Frank
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#11
Zitat:...das hier, das schmeiß mal zuerst raus. (Siehe Quelltext-rot)

<html xmlns="http://www.w3.org/1999/xhtml" lang="de" xml:lang="de">

Moinsen,

hm, okee. Aber warum? Wie gibt man die Sprachversion der Website denn heutzutage mit Mobirise an? Huh

@Stobi_de

Aha. Ja, das ist tasächlich ein Menü aus einem anderen Theme. Für die Seite nutze ich Agency M4. Aber die sollten doch alle kompatibel sein. Sehr unschön, aber das würde evtl die fehlende Navigation unter Firefox auf Mobilgeräten erklären.
Werd ich umgehend umbauen. Danke für den Tipp!

Die Seitennamen wären eh mein nächster Schritt gewesen.
OG-Tags? Wofür braucht man die?
Ich verschenke Alt-texte? Ich dachte genau die wären u.a. wichtig.

Lg.
Chris
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
#12
Ja, die Alt-Texte sind sehr wichtig.
Da würde ich die aber anders nennen, also mit Deinen Suchbegriffen drin und nicht "Wappen oder Plakette", eher sowas wie "Wappen Kaminofen Schweden"

Die Kompatibilität funktionierte bis version 4.7.8 sehr gut, danach gar nicht mehr, aktuelle wieder besser, muss aber neu gebaut werden.

Die OG-Tags sind für Facebook und Co.
Wenn Deine Seite mal durch Facebook wandern sollte, was Google natürlich gut fände, hättest Du dann auch die richtigen texte und Bilder drin.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  mobirise pagespeed optimieren Thomasold 5 45.417 10.08.2017, 00:09
Letzter Beitrag: vloppy



Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
nach oben An den Anfang der Seite scrollen
NetObjects Fusion Infos, Downloads und Updates Diese Website wird durch Bot-Trap vor Spam geschützt!